When do I need to get new terminals?

Our older range of terminals are not able to support Terminal API functionality. If you are not using Terminal API already, then you will need terminals which work with Terminal API.

In case you are using a VX675, VX680, VX690, VX820, e315 or e355 it will need to be replaced with a Terminal API-compatible device before March 29th 2024

The PCI expiry dates are also a major factor for terminal deprecation timelines. This PCI certification expiry also affects the MX925 in addition to the above terminals.

Was this article helpful?
0 out of 0 found this helpful