What version(s) of TLS does Adyen support?

All merchant integrations with Adyen must use TLS 1.2.

The PCI Security Standards Council (PCI SSC) no longer accepts early TLS (TLS 1.0) as a secure communication protocol for transmitting payment card data, and we have therefore disabled older versions of TLS on our platform.

Note: Integrations such as Java 7 or .NET 4.0 don’t support TLS 1.2 using default configurations. Integrations using Java 6 and below, .NET 3.5 and below, Python 2.7.8 and below, Ruby 1.9.3 and below, OpenSSL 1.0.0 and below will all be difficult or impossible to configure to use TLS 1.2, and significant migration effort may be required by the merchant. Additionally, shoppers using old browsers (IE8 and IE9 as well as Android versions 4.4 and below) that only support early TLS in combination with Hosted Payment Pages (HPP) and Client Side Encryption (CSE) will not be able to connect to these services.

TLS 1.0 must not be used to protect payments data or payments pages after June 30th 2018.

Was this article helpful?
2 out of 2 found this helpful